Skocz do zawartości
Szukaj w
  • Więcej opcji...
Znajdź wyniki, które zawierają...
Szukaj wyników w...
blanken

[Rozwiązane][qBot] adminStatusOnChannel - wyświetlanie

Rekomendowane odpowiedzi

Napisano (edytowane)

Rodzaj aplikacji: qBot

Opis problemu: problem z funkcją adminStatusOnChannel. Mianowicie chodzi o to, że:

1. Po ustawieniu statusu na danym kanale w funkcji działają tylko statusy "online" oraz "away" - w momencie opuszczenia serwera pozostaje uprzedni status (online lub away)

2. Po ustawieniu kolejnego statusu (do drugiego admina) funkcja nie działa na drugim kanale - pierwszy działa z powyższym błędem

Generowane błędy: brak

Zawartość pliku konfiguracyjnego [config.php]: poniżej

Zawartość pliku z logów: brak

Dodatkowe uwagi:

 

    'adminStatusOnChannel' => [
      'enabled' => true,
      'interval' => 5,
      'awayTime' => 15,    # Czas, po którym nazwa kanału zmieni się na away
      'channelName' => "[cspaceradm]Aktualnie jest » [status]",    # Wzór nazwy kanału
      'on' => "online",
      'off' => "offline",
      'away' => "na przerwie"
    ],

 

!adminStatusOnChannel list

<17:03:00> "xxx @ Naczelnik":    ID kanału: 3 przypisany do dbid: 27 
<17:03:00> "xxx @ Naczelnik":    ID kanału: 17 przypisany do dbid: 34 

Gdzie: 3 oraz 17 to ID osób użytkownika a 27 oraz 34 to id kanałów 

(Bot prawdopodobnie źle wyświetla info - po zmienieniu ID usera z ID channelu zmienia nazwę niepożądanego kanału)

Edytowane przez blanken

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
!adminStatusOnChannel add <cldbid> <channelid>

 

Dodajesz w ten sposób? Najpierw database ID osoby, potem ID kanału.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
<20:20:22> "xxx @ Naczelnik":    ID kanału: 3 przypisany do dbid: 27 

Usunąłem i dodałem ponownie tak jak mówisz, jednakże teraz to już kompletnie nie działa. Nie zmienia się status w kanale

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

php core.php -i 3 

pokaz czy nie swiruje z bledami

  • Lubię to! 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
                                   ____        _
                              __ _| __ )  ___ | |_
                             / _` |  _ \ / _ \| __|
                            | (_| | |_) | (_) | |_
                             \__, |____/ \___/ \__|
                                |_|

                             Autor:  Stalker
                             Wersja:  4.1
                             Telegram:  @Stal_ker
                             TS:  Jutuby.net

[->]Ładowanie potrzebnych plików...
[->]Sprawdzanie plików cache...
[->]Wybrano instancje numer:3
[->]Pomyślnie połączono z serwerem!
[->]Pomyślnie zalogowano na query!
[->]Pomyślnie wybrano serwer!
[->]Bot zmienił nazwę na xxx @ Aktualizator
[->]Bot zmienił kanał na 3
Podgląd:
    - adminList
    - multiFunction
    - kickFromCp
    - dataCopy
    - autoPoke
    - serverName
    - adminStatusOnChannel
    - serverName
    - adminStatusOnChannel
    - autoPoke
    - serverName
    - adminStatusOnChannel
    - autoPoke
    - serverName
    - adminStatusOnChannel
    - multiFunction
    - serverName
    - adminStatusOnChannel

@Angel. , proszę

 

@edit

Po wpisaniu 

 

php core.php -i 3 

zaczęło banglać

 

Edytowane przez blanken

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

problem rozwiązany, zamykam

  • Lubię to! 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...