Skocz do zawartości
Szukaj w
  • Więcej opcji...
Znajdź wyniki, które zawierają...
Szukaj wyników w...
Donix

[Rozwiązane][qBot] Niektóre funkcje nie działają

Rekomendowane odpowiedzi

Rodzaj aplikacji: qBot

Opis problemu: Funkcje: "autoPoke", "serverName", "autoRegister" nie działają.

Generowane błędy: Gdy włączam bota poprzez ./run start to mam kilka błędów, ale bot łączy się z serwerem i funkcja "getPrivateChannel" działa:

 

[email protected]:/home/qbot/qBot_v4.1# ./run start
Starting!
   - instance is already started! (1)
   - instance was not started! Check the config file! (2)
   - instance was not started! Check the config file! (3)
   - instance was not started! Check the config file! (4)
   - instance was not started! Check the config file! (5)

 

Gdy włączam poprzez "php core.php -i 1" to nie ma tego błędu.

Zawartość pliku konfiguracyjnego [config.php]: Funkcja autoPoke:

 

        Funkcja informująca administratorów o pobycie klienta na centrum pomocy
    */
    'autoPoke' => [
      'enabled' => true,
      'interval' => 7,
      'cfg' => [
        0 => [
          'channelId' => 27,    # Id kanału centrum pomocy
          'blockedGroups' => [],    # Blokowane grupy | Jeśli zostawimy puste nie będzie blokowanych grup
          'adminGroups' => [6],     # Grupy administracji
          'ignoredGroups' => [],    # Ignorowane grupy
          'ignoredAdminGroups' => [],   # Ignorowane grupy administracji, jeśli admin będzie miał te grupy nie otrzyma powiadomienia
        ],
      ],
    ],

 

Funkcja serverName:

 

        Funkcja edytująca nazwę serwera
        Zmienne:
        [on] - online na ts
        [max] - ilość slotów
        [proc] - procentowe zapełnienie serwera
    */
    'serverName' => [
      'enabled' => true,
      'interval' => 5,
      'serverName' => "Donix. pl | Online: [on]/[max]"   # Wzór nazwy serwera
    ],

 

Funkcja autoRegister i topTimeSpent:

 

 

        Funkcja nadające grupę serwera, jeśli klient spędzi określny czas na serwerze
        Potrzebna funkcja 'topTimeSpent'
    */
    'autoRegister' => [
      'enabled' => true,
      'interval' => 55,
      'groupAdd' => 9,   # Id grupy serwera
      'requiredTime' => 2,   # Wymagany czas (w sekundach)
      'groupsIgnore' => []    # Ignorowane grupy
    ],

    'topTimeSpent' => [
      'enabled' => true,
      'interval' => 60,
      'ignoredGroups' => [],    # Ignorowane grupy
    ],

 

 

Zawartość pliku z logów: Nie mam wygenerowanych

Dodatkowe uwagi: Tak jak pisałem wyżej. Te funkcje nie działają, a "getPrivateChannel" normalnie działa. Proszę o pomoc 🙂

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Aha dobra z tym ./run start to wszystko ok bo tylko pierwsza instancja jest włączona. Dopiero teraz się skapłem 😅.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

@Donix z tego co widzę odpalasz tylko pierwszą instancję, a chcesz używać funkcji, które są w innych instancjach.

Musisz wpisać dane do logowania nie tylko dla pierwszej instancji, ale dla pozostałych, które chcesz używać też.

https://prnt.sc/s8h9sb

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
1 minutę temu, Stalker napisał:

@Donix z tego co widzę odpalasz tylko pierwszą instancję, a chcesz używać funkcji, które są w innych instancjach.

Musisz wpisać dane do logowania nie tylko dla pierwszej instancji, ale dla pozostałych, które chcesz używać też.

https://prnt.sc/s8h9sb

xD Rzeczywiście. Dzięki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...